Add Book to My BookshelfPurchase This Book Online

Chapter 13 - Configuring IGRP

Cisco & IP Addressing
Louis D. Rossi, Louis R. Rossi and Thomas Rossi
  Copyright ⌐ 1999 The McGraw-Hill Companies, Inc.

Chapter 13: Configuring IGRP
Overview
Interior Gateway Routing Protocol (IGRP) is a Cisco proprietary protocol. Cisco defines IGRP as an advanced distance-vector routing protocol.
IGRP is also a classful routing protocol, which means it does not support VLSM.
IGRP has several unique features, which is why Cisco calls it an advanced routing protocol.
Those features are as follows:
  1. Scalability—IGRP is not limited to 15 hops as is IP RIP.
  2. Event-triggered updates—IGRP sends updates when topology changes occur.
  3. Multiple paths—IGRP has the ability to keep track of multiple routes that have an equal as well as an unequal metric.
  4. Sophisticated metric—IGRP uses a combination of metrics to determine the best route.
The metrics are:
  Bandwidth
  Delay
  Load
  Reliability
  Maximum Transmission Unit (MTU)
As we discussed in the previous chapter, IP RIP bases its routing decision based on hop count.
IGRP determines the best path by accounting for bandwidth as part of the metric, thereby providing for a more sophisticated determination of the best path. Refer to Chapter 5 for a review of this concept.
Refer to Figure 13.1 and Table 13.1.
Table 13.1 Addresses to be Used for Figure 13.1
S0
S1
S2
E0
Router_A
10.10.8.9
N/A
N/A
10.10.1.1
Router_B
10.10.8.1
10.10.12.1
10.10.4.1
N/A
Router_C
10.10.12.9
N/A
N/A
10.10.2.1
Router_D
10.10.4.2
N/A
N/A
10.10.3.1
Mask
255.255.255.0
255.255.255.0
255.255.255.0
255.255.255.0
Figure 13.1  Four-Router Topology
Configuration Commands
Figure 13.2 shows the commands to configure IP addresses and IGRP on Router_D.
I have included the IP address configuration lines as a review.
Router_D# config t
Enter configuration commands, one per line.  End with CNTL/Z.
Router_D(config)#int e0
Router_D(config-if)#ip address 10.10.3.1 255.255.255.0
Router_D(config-if)#int s0
Router_D(config-if)#ip address 10.10.4.2 255.255.255.0
Router_D(config-if)#router igrp 100
Router_D(config-router)#network 10.0.0.0
Router_D(config-router)#
Router_D#
%SYS-5-CONFIG_I: Configured from console by console
Router_D#
Figure 13.2  IGRP Configuration Commands
As with IP RIP, IGRP is classful so we only identify the major network address. Configuring IGRP is similar to configuring IP RIP; the one difference is we use a Autonomous System (AS) number. This AS number defines an area for which we have control. In most cases this number will remain the same throughout the topology. In our case all routers will carry an AS number of 100.
Verifying Configuration
After Router_D is configured we should verify that our configuration is correct.
The “show run” command (Figure 13.3) will help us verify that we have configured our addresses and the IGRP protocol correctly.
Router_D#show running-configuration
Building configuration...
Current configuration:
!
version 11.3
no service password-encryption
!
hostname Router_D
!
interface Ethernet0
  ip address 10.10.3.1 255.255.255.0
!
interface Serial0
  ip address 10.10.4.2 255.255.255.0
  no ip mroute-cache
  no fair-queue
  clockrate 56000
!
interface Serial 1
  no ip address
  shutdown
!
router igrp 100
  network 10.0.0.0
!
ip classless
!
line con 0
line 1 8
line aux 0
line vty 0 4
!
end
Figure 13.3  The “show run” Command
Figure 13.3 shows that the proper addresses are configured on the correct interfaces and IGRP will advertise network 10.0.0.0.
The “show ip protocol” command (Figure 13.4) will display all the IP protocols currently configured on the router.
Router_B#sh ip prot
Routing Protocol is "rip"
  Sending updates every 30 seconds, next due in 17 seconds
  Invalid after 180 seconds, hold down 180, flushed after 240
  Outgoing update filter list for all interfaces is not set
  Incoming update filter list for all interfaces is not set
  Redistributing: rip
  Default version control: send version 1, receive any version
    Interface        Send  Recv   Key-chain
    Serial0            1   1 2
    Serial1            1   1 2
    Serial2            1   1 2
  Routing for Networks:
    10.0.0.0
  Routing Information Sources:
    Gateway         Distance      Last Update
    10.10.8.9            120       00:00:26
    10.10.12.9           120       00:00:01
    10.10.4.2            120       00:00:07
  Distance: (default is 120)
Routing Protocol is "igrp 100"
  Sending updates every 90 seconds, next due in 58 seconds
  Invalid after 270 seconds, hold down 280, flushed after 630
  Outgoing update filter list for all interfaces is not set
  Incoming update filter list for all interfaces is not set
  Default networks flagged in outgoing updates
  Default networks accepted from incoming updates
  IGRP metric weight K1=1, K2=0, K3=1, K4=0, K5=0
  IGRP maximum hopcount 100
  IGRP maximum metric variance 1
  Redistributing: igrp 100
  Routing for Networks:
    10.0.0.0
  Routing Information Sources:
    Gateway         Distance      Last Update
    10.10.8.9          100          00:01:00
    10.10.12.9         100          00:00:13
    10.10.4.2          100          00:00:15
  Distance: (default is 100)
Figure 13.4  The “show ip protocol” Command
Figure 13.4 shows that IP RIP and IGRP are both configured. The router will only use one protocol per network to determine the best path. Do you remember how the router determines which protocol to use?
Viewing the Routing Table
Router_B#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
    D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
    N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
    E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
    i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, * - candidate default
      U - per-user static route, o - ODR
Gateway of last resort is not set
    10.0.0.0/24 is subnetted, 6 subnets
I   10.10.1.0 [100/8576] via 10.10.8.9, 00:00:26, Serial0
I   10.10.2.0 [100/8576] via 10.10.12.9, 00:00:58, Serial1
I   10.10.3.0 [100/89056] via 10.10.4.2, 00:01:07, Serial2
C   10.10.4.0 is directly connected, Serial2
C   10.10.8.0 is directly connected, Serial0
C   10.10.12.0 is directly connected, Serial1
Figure 13.5  The “show ip route” Command
Router_B has 3 directly connected networks and 3 routes that are discovered by the IGRP process.
The default administrative distance of IGRP is 100. Take note when viewing the configuration file that IP RIP is still configured, yet all of our routes are discovered through IGRP. The lower the administrative distance, the more reliable the routing protocol (Chapter 5). Therefore, the networks learned by the RIP process are ignored.
The metric for IGRP is the result of a calculation that IGRP performs. At this point do not be concerned with the actual number; what is important to know is the lower the number the better the route.

 


 
Books24x7.com, Inc ⌐ 2000 –  Feedback